2560x1440_HeroIMG_Tandem_Device_Updater
TDU_Icon_250x200

Tandem Device Updater

 

Innovation delivered in real time

The Tandem Device Updater is a Mac® and PC-compatible tool for the remote update of Tandem insulin pump software. This tool allows us to provide our customers access to new and enhanced features faster than the industry has been able to in the past, and separate from the typical multi-year warranty cycle.
 
 
 

Coming soon...


The first use of the Tandem Device Updater will be for deployment of the latest t:slim® Insulin Pump software to t:slim Pumps purchased before April 2015.  This updated software, based on customer and healthcare provider feedback, includes an expansion of the reverse correction functionality, the ability to enter a manual bolus directly in the suggested bolus window, off-pump cartridge filling, and other features to enhance convenience and flexibility.

 
Did you receive your t:slim Insulin Pump before April 2015?

If you received your t:slim Pump before April 2015 and would like to help us beta test the Tandem Device Updater this summer, please provide your information here. Beta testers will be chosen on a first-come, first-served basis over the next 4-6 weeks.
 

Sign up to participate in our beta tests.

 
 
 
 

What software is my t:slim Pump running?

 
The updated software that started shipping in April 2015 uses on-screen buttons with square corners. The original t:slim Pump software uses rounded corners. If your pump screen’s buttons have rounded corners like the "Original t:slim Pump" images shown here, you are eligible to participate in the Tandem Device Updater beta test.  Please see the System Requirements below for a list of computer and software requirements needed to run the Tandem Device Updater.

  
TDU_GUI_Screen_Details

 
 
 
900

System Requirements

To update your pump, one of the following operating systems is required:

  • Microsoft® Windows® 10 (32 or 64 bit)
  • Microsoft® Windows® 8 (32 or 64 bit)
  • Microsoft® Windows® 7 (32 or 64 bit)
  • Mac® OS X® El Capitan (v10.11.x)
  • Mac® OS X® Yosemite (v10.10.x)
  • Mac® OS X® Mavericks (v10.9.x)

The following are the minimum computer requirements:

  • 1 GB RAM
  • 1 GB of available disk space
  • x86 compatible
  • 1.6 GHz processor or faster
  • USB 1.1 port or later
  • Screen display capable of at least 1024 by 768 resolution

In order to install the Device Updater, you will need sufficient access rights on your computer.