Device Compatibility

Gear

Bolus delivery from the t:connect mobile app requires a compatible smartphone model and operating system. Before you get started, let's make sure your device is compatible.

Select Your Device

* To find out what operating system is installed on your Apple device, go to iOS Settings, General, and then About. On an Android device, go to OS Settings, About Phone, and then Software Information.

Note: In order to use the bolus feature within the t:connect mobile app you must have a compatible smartphone, operating system, and be running software versions 6.6 (Basal-IQ Technology) or 7.6 (Control-IQ Technology), or newer, on your t:slim X2 insulin pump. This form reflects the devices that are compatible with the most up-to-date t:connect mobile app version.

t:connect Mobile App with Bolus Delivery
App FeaturesCompatible
Bolus From Your Smartphone 
View Pump Data 
Receive Alerts as Push Notifications 
Wirelessly Upload Pump Data 
Your model and operating system are compatible with all app features
App FeaturesCompatible
Bolus From Your Smartphone 
View Pump Data 
Receive Alerts as Push Notifications 
Wirelessly Upload Pump Data 
Your model and operating system are not compatible with the bolus feature
App FeaturesCompatible
Bolus From Your Smartphone 
View Pump Data 
Receive Alerts as Push Notifications 
Wirelessly Upload Pump Data 
Your model and operating system are not compatible with the app

Freedom to See Clearly

Your device is not compatible with the bolus feature, but you can still use the t:connect mobile app as a discreet, secondary display for your t:slim X2 insulin pump data, settings, or sensor status.

Compatibility

The bolus feature within the t:connect mobile app can be used with the following smart­phone models and operating systems. You also must run software versions 6.6, 7.6, or higher on your t:slim X2 insulin pump, so please make sure to update your pump.

Note: We are actively working to add more supported models and operating systems to this list. If your model is not currently supported, you can still utilize the other features within the t:connect mobile app (assuming it uses a supported operating system).

§ Minor operating system updates will remain compatible (i.e. iOS 15.1, iOS 14.2 etc.), customers should wait to update to any major release (i.e. iOS 16, Android 13) until we have confirmed compatibility.

Apple iOS 14 or 15§

  • iPhone 7 or 7 Plus
  • iPhone 8 or 8 Plus
  • iPhone 11, 11 Pro, or 11 Pro Max
  • iPhone 12, 12 Mini, 12 Pro, or 12 Pro Max
  • iPhone 13, 13 Mini, 13 Pro, or 13 Pro Max
  • iPhone SE (2nd Generation)
  • iPhone XR
  • iPhone X, XS, or XS Max

Android OS 10, 11, or 12§

  • Samsung Galaxy Note 20 or Note 20 Ultra
  • Samsung Galaxy S20, S20+, S20 FE, or S20 Ultra 5G
  • Samsung Galaxy S21 5G
t:simulator App

Download

Your Device is Compatible

Download the t:connect Mobile App Today!

Give yourself the freedom to more easily manage your diabetes with the t:slim X2 insulin pump and t:connect mobile app.

How to Update

After downloading the t:connect mobile app, follow these detailed instructions to update your t:slim X2 insulin pump.